What's gone wrong with today 's event?

Clicked to play today’s event but, after playing loads of games - and should be well on the way to hitting the target - now invited to enter again, so nothing accrued yet and still not showing in the Quests window.


Something is strange with it. Mine would not let me pick the wild card one. It would not start no matter how many times I tried or restarted the game it would not appear. I got the volcano one to work, and it is counting up.

Quest wouldn’t load for me either. I sent a request to tech support this morning. I haven’t heard anything yet. I dont want to play because my winnings aren’t being added to quest?

1 Like

Me too. Tried for the wildcard but it doesn’t work.

1 Like

Same here. Entered event, but nothing shows. I see progress in other quests

1 Like

I’ve just posted the same thing! Others in my team are complaining Too!

1 Like

Same thing is happening to me with the wild card option.

1 Like

Same issues here on quest not working

I sent also sent a request to tech support.

I to clicked on a event and nothing showed up. Does anyone know to fix this

I am having the same issue. Won’t work for the wild cards.

I am having the same issue.

Were all having issues in my club too

Mine wont work for wilds either but a teammate tried the coins option and hers isnt loading either

Continuing the discussion from What's gone wrong with today 's event?:

Mee too comment do wild cards try and try nothing

Same here. Told customer service, but as usual they don’t care

I am completely locked out of game. Cannot contact team leader. Tried tech support also???