Update won't install

I was playing the game fine on my Chromebook yesterday morning, but I returned later that afternoon, the app reloaded, And I saw update is available. But when I clicked on Update, nothing happens. I tried repeatedly, still nothing. Only other option in that same window is Help, which is a form for their tech support. I did submit request for help, but as yet, no response. I don’t want to lose my status and rewards, as I’ve done in the past.

I’ve forced stopped the app, and cleared the cache repeatedly, but that isn’t helping either.

Hoping someone has ideas to help.

Thanks in advance.


@sas300dx, it sometimes takes a couple of days to hear back from support, depending on how busy they are.

Did you try powering your chromebook off and back on? Or uninstalling and reinstalling the game app?

If all that fails, did you have your TriPeaks game linked to FB or Apple ID? If so, can you play on a different device until this is fixed?


Thanks for the response. Yes, I’ve contacted support in the past, and do realize it’ll be a few days for a response. In which time, I’ll already have lost, at the least, my daily sign in bonus, and whatever else. The system will probably put me back to Day 1 anyway, instead of 255 where I should have been, for not being able to play daily.

I’m loathe to uninstall the app, for the same reason - losing everything I’ve worked for, because the system will regard me as a new player, and I’ll have to start at the beginning, all over again. I don’t want to do that if there’s some way I don’t have to. I guess I’ll just wait till hear from support.

Thanks again for the response.


@sas300zx, as long as you are on the same device, uninstalling and reinstalling will not lose any progress!

Also, if you write to them again and tell them about losing your daily sign in bonus progression while you were waiting - i have seen them correct that too. Just don’t give up!

It never hurts to ask!


I’ll have to think about uninstalling on this Chromebook. I’m not convinced I won’t lose my previous place.

And yes, I’ve written to support in the past, asking then to replace lost daily bonuses, and they have. They can see players’ activities, so they do know when things have been lost, and have replaced them.

And no, it never hurts to ask!

Thank you,.



I’m still waiting a response from support. Meanwhile, it’s been 2 days now, and can’t play because the update problem continues. I’ve restarted my Chromebook again, hoping it would help. It didn’t. I still don’t want to uninstall/reinstall because I feel sure I will go back to being recognized as a new player, instead of a multiple club champ on what should have been day 257 or so. The wait continues.

@sas300zx, even before I created a FB account to log into for extra TriPeaks account, I uninstalled and reinstalled many many times, and didn’t lose anything.

The only time I lost anything is when I thought I had to do a factory reset on my tablet to get TriPeaks back. That erased the game progress that was stored on my tablet.

I have one more TriPeaks account that is not connected to FB or Apple ID yet. I recently uninstalled and reinstalled on that device (I prefer to uninstall before updating), and didn’t have a problem. On this particular device, I’m waiting for the option to sign in with an Apple ID just so I can see what that’s like (my other 4 accounts have their own FB accounts - did I mention I’m addicted? LOL)

Anyway, keeping my fingers crossed :crossed_fingers: that you find a solution soon!

Keep us posted!


Ok, I finally uninstalled, as I couldn’t play anyway. It’s been days now, and support was not helpful. Now, when I tried to reinstall, I ran into problems. I used Google Play on my Chromebook to install. As I tried to install, I could choose which to install to - my Android phone, or my Chromebook.

I chose my Chromebook, and it showed as installed, but I clicked on the Installed link anyway, and a small pop-up window appeared. The window was blank, except for a green Ok button. I clicked on that, and looked on my device to find the app. I found nothing. I tried multiple times, with the same result. Nothing. I searched on my device for it, but got no result.

I don’t understand how people have been saying they uninstalled and reinstalled multiple times, when I apparently can’t do it once.

That is odd because I just recently got Facebook and linked my acct and before I was never linked to anything and would Uninstall and reinstall with no problem.
I’m sorry to hear you having such a issue, hope it resolves soon for you.

1 Like

I don’t do FB, so I can’t comment on that. I’m at a standstill now, as I’m still not able to figure out how to reinstall it on my Chromebook. I may have been removed now, for not playing for so many days. :frowning_face:

What club do you play in @sas300zx?

Sorry, I wish I could remember, but as a stroke survivor, I have “stroke-brain,” meaning short-term memory loss. I had to join a club, otherwise my play was pretty much limited, so I chose a club that didn’t have a lot (any) play requirements. I think I’d know the name if I saw it, but I didn’t pay that much attention to the name of the club, only that I was on one. Sorry I can’t be more help.

Meanwhile, I spent a good part of the day today, trying anything I could think of, to try and reinstall the app on my Chromebook. So far, nothing works, so I don’t know what else I can do. :cry:

So sorry to hear that @sas300zx, on both accounts. My sister had a stroke, so I understand - besides, I think a lot of people don’t pay attention to the club name. I was just going to try to get ahold of your leader for you, to let them know of your troubles.

Did you ever hear back from support? What version of chromebook do you have?


No, I never heard anything more back from support, after I responded to the first response, which talked about changing country settings, which made NO sense. I just emailed support again, in a last ditch effort.

Thanks for trying to reach out to my club leader. It’s very kind of you, and much appreciated. Honestly, I don’t know who that is either. I play daily, and basically play to challenge myself, to score and get on the leader boards as high as I can.

I can’t remember the name of my club, but I think it’s something like TriPeak Pros. Not positive though, only that I’m pretty sure the name starts with TriPeaks, which I realize is not much help.

I am still trying to find a way to reinstall the app on my device, but not having any luck there, either. I have an Asus Chromebook Flip C302, with all updates. I just checked, and it says my most current OS is Version 84.0.4147.127.

Since it’s been so long, I’m already guessing I’ve been removed, although the club I’m in is pretty casual, and I think I’m one of the more active, if not the most active player, playing daily, for hours at a time, or longer.

Now waiting to hear back from support once again, although I don’t expect anything until Monday, at the earliest. :sob:

Well @sas300zx, I’ve been doing some research, because my tablet now could not download the game. My first response back from support was to suggest I clear some space, even though I clearly told them the notification said my device was no longer supported. I went ahead and cleared some space, and tried to download again, to no avail - I was given the same message that my device was no longer supported. So I wrote back to support again, and they said, oh, well, you have to have Android 5.0 or better. I didn’t have that, so my tablet was useless (until I had my son root the tablet and install Android 5.0 on it LOL - that was last night).

Back to you though… so I got to thinking, maybe your OS version was out of date… but it’s not. That version just released on August 13th, and is the most current version, so that’s not it. August 13th is after you started having problems (you first wrote here on August 6th), so it wasn’t something in your update that caused the problem either.

Do you get your apps from the Google Play Store? Have you tried downloading others to see if that still works?

Have you heard from support yet?

1 Like

Yes, that’s what support told me too - that this app is not supported on my Chromebook. Yet it was playing fine until their last update. Up to that time, it seemed that when I was actively playing, and was notified of a game update, I could update with no problem. But I don’t know what happened - I left the game in the morning, to go to a dr appt, and when I came back to it in the afternoon…well, this happened. I’ve been trying to figure out something ever since.

Yes, this app came from the Google Play Store. I did do a general Google search for this app, in hopes of finding a different way to dl it. Not really, although Amazon was there, which is where I got it initially, years ago, for my Kindle devices. Playing it there was what made me want to get it when I got my new Chromebook.

Now, however, as I think I mentioned above somewhere, when I try the Google Play Store again, it shows me an option to install to my Android cellphone, or to my Chromebook. I first tried installing to my cellphone, and that worked. I then tried installing to my Chromebook. I got a blank little white box, with a green OK button. I clicked OK, then went looking for the app, but nothing. I tried it several times with the same result. Nothing.

I did try installing other stuff, just to see if it was something about the Play Store. I got a quick message about there being some unnamed problem at their end, and to try again later. I have. It’s the same - that small blank white box with the green OK button. Repeatedly.

I’ve already contacted Google “support,” but after that initial reply days ago, I’ve heard nothing more. BUT, I did get a survey asking how the Google support agent was. ROTFLMAO. I told them. That’s the last I heard, days ago.

So now I’m out of ideas. I wouldn’t want to root out my Chromebook, so that’s out.

I guess if there’s any bright side to this, now I have more time in my day, to do other things that tend to pile up when I’m engrossed in the game. :grinning:

But, I’m sure I’ve been tossed out of my club. I contacted support again on Thursday or Friday, telling of my current situation, and asking if they could please tell me the name of my (former) club. Since I know there will be no response over the weekend, I waited until maybe today for something. But so far, nothing. I’ll wait until Tuesday, maybe they’re backlogged with emails, so I guess I’ll just wait some more. :pensive:

Ok, here’s my latest (and last?) response from support:

"Please understand that Guest accounts are device-specific. If you previously logged in as a Guest, your account will not transfer to a new device. By signing in with Facebook or Apple ID on your old phone or tablet, you will then be able to transfer your account - and associated progress - to any new devices. (Note: you can only transfer your Guest progress to a Facebook or Apple ID account once).

Currently, Facebook and Apple ID are the only ways to save and transfer your progress. We are unable to combine, transfer, or delete accounts.

Please let us know if you have any other questions – we’re happy to help. Have a great day!"

They didn’t respond about what club I used to be in, though. :sob:

But from what I’m understanding, that’s the exact reason I was so reluctant to uninstall earlier, for fear of losing my prior place, and having to start over. But since I couldn’t play anyway, because of something about their last update, I had no choice. But because I don’t do social media, or Apple, I guess that’s it for me. Until I can find a way to reinstall on my Chromebook. :thinking:

Wow @sas300zx, so TriPeaks support told you the game is not supported on your chromebook, did they say what about your chromebook is not supported? Mine worked fine until the last update too. I asked them if it was possible to install the previous version, and that question wasn’t answered, so I guess that’s a no.

Rooting my tablet didn’t work out so well. I could install the game, and get in, but it kept freezing after playing for a couple minutes. My tablet is old, so I don’t use it for tripeaks anymore. Fortunately, my about in that device was l logged into FB, so I can switch accounts on my phone, and still play that account.

Also, I created a club, that is now completely inactive, and I asked support to delete that club. I was told I have to send a ticket using the help button while I’m in that club so they can find it.

Do you have another device that you can just start over? If you have another device and decide you want to start playing again, you are welcome to join one of our clubs, that requires different amount of points depending on how much you want to play, ranging from just play once or twice a week, to 25,000 points a week. Our members move from club to club depending on how much time they have to play.

Here’s more info on our clubs:
Join the Play4perks Menagerie

I apologise for how long it took me to get back to you. I took a few days off, to prepare for a surgery on my knee. Now that’s done (it was success :slight_smile:), and now I’m sitting in the hospital for a couple days with lots of time! LOL

1 Like

Sorry for not replying until now. I thought I had, but it looks like it never made it here. It looks like I’m back. I just started playing around again with Google Play Store. I re-read the troubleshooting tips for what if Play Store won’t install apps, and went through the list, one by one.

I’m back, for now, but in some ways only. It did already know my previous user name, but I am having to go back and re-check settings, like turn off sound. I did lose my multi-time champ status, but didn’t lose coins. I am starting back at Day 1, but when game finally loaded, after several tries, it put me right back to the the same level I last left when last update froze me out. Being back at Day 1, it’s already telling me I need to join a club, and that I have been removed from my last club. I’ll look and see if it’s the one I last remember, but I’m not sure. And whether I’ll be able to load game again next time.

1 Like