My Amazon version is stuck in update loop

When I open my amazon app store version of the game it doesn’t fully load before a pop-up appears telling me I must update the game. When clicked on, it takes me to the game page within the appstore where another pop-up immediately appears asking me to open the amazon appstore (!!) So I click on that and it reopens the appstore to the game page, but the page shows no update available. I’ve uninstalled/reinstalled both the game and the appstore but nothing helps. This has gone on since Oct. 17-18th. Incredibly frustrating to not be able to get into the club that I lead! It’s been 2 weeks! Help!

I am assuming you can’t get on the game at all, I recall someone else with a similar device stating they also were having issues, here is their email address to contact support, if you cannot reach the help icon in the game, I will also flag it in the hope to speed up the process.


My wife is having the same issue. Yet I am curiously not. Just a guess, but since there are OH SO MANY versions of the devices, and an equal number of versions of the operating system it may be system specific. I’ll update this reply with her device info before the night is out. Hopefully this helps get the issue resolved.


Hi folks - if you haven’t tried deleting and reinstalling the app, then give that a try first. If it’s still behaving that way, make sure you’ve updated to the latest OS for your device. If all of that checks out, and you’re still unable to open the game, then please contact our Player Services department at :slight_smile:


@Kristine_PDX, has this resolved for you yet?

Another suggestion - reboot your device. If you have and that, and everything else has not worked, did you contact the email that @Tiki-Tahd suggested? Please keep us posted :slight_smile: